Autor Thema
electrom

Registriert: 11.08.2011
Beiträge: 296
Land: Deutschland

Nach Umstellung auf SSL, Warnung Mixed Content      Erstellt am 09.05.2019 um 12:54:43   
Hallo,

Nach der Umstellung auf SSL unseres Online Shops und dem Angleichen der Bildpfade von http:// auf https:// erscheint in der Browserconsole folgende Fehlermeldung:

Mixed Content: The page at 'https://www.electromyne.de/' was loaded over HTTPS, but requested an insecure image 'http://www.afterbuy-shop.de/'. This content should also be served over HTTPS.

Ich habe schon alle Templates nach dem Bildpfad http://www.afterbuy-shop.de/ durchsucht, leider ohne Erfolg.

Gruß
Denny
Dennis P.

[Afterbuy Support]

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 09.05.2019 um 13:21:59   
Hallo Denny,

wie ist denn in dem Fall Deine Kundennummer, damit ich mir das einmal anschauen kann?

Gruß Dennis

electrom

Registriert: 11.08.2011
Beiträge: 296
Land: Deutschland

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 09.05.2019 um 13:43:48   
Hallo Dennis,

unsere Kundennummer lautet 96621

Gruß Denny

Dennis P.

[Afterbuy Support]

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 09.05.2019 um 14:42:15   
Danke. Ich werde das einmal kontrollieren, aber bisher fand ich nichts, auch im Seitenquelltext nicht,
was dies auslösen könnte, da auch afterbuy-shop.de nirgends darin vorkommt.

Gruß Dennis

Dennis P.

[Afterbuy Support]

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 09.05.2019 um 14:58:04   
Du hast in dem Design, was Du hier verwendest, HTTP Verweise auf die Kategorien. Wenn man z.B. auf der
Shop Startseite nach unten scrollt, gibt es einen Bereich der so anfängt:

"Unser übersichtlicher Onlineshop bietet eine einfache Navigation, die eine schnelle und problemlose Orientierung gewährleistet:"

Darunter kommen dann Auflistungen, auf denen auf eine Kategorie im Shop verwiesen wird, welche mit
HTTP Angaben gemacht wurden. Diese müßen durch HTTPS ersetzt werden, dann sollte damit in der
Regel auch der SSL Fehler (bzw. nicht sichere Seite) verschwinden.

Gruß Dennis

electrom

Registriert: 11.08.2011
Beiträge: 296
Land: Deutschland

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 09.05.2019 um 15:18:53   
Nein,

die Fehlermeldung lautet:

Mixed Content: The page at 'https://www.electromyne.de/' was loaded over HTTPS, but requested an insecure image 'http://www.afterbuy-shop.de/'. This content should also be served over HTTPS.

Es geht um ein Bild das auf jeder Seite aufgerufen wird. Egal ob nun Start-, Kategorie- oder Unterseite.

Gruß
Denny

Pascal M.

[Afterbuy Support]

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 09.05.2019 um 16:59:52   
Hi Denny,

ich kann leider auch kein Bild finden was hier noch eine http:// Adresse hat.

Du solltest aber die Links die noch auf einen http:// verweisen trotzdem austauschen, diese fühern auch zu einer nicht sicheren Seite.
Genauso verlinkt dein Logo auch auf http://www.electromyne.de/ das solltest du auch in https:// ändern.
Wenn du die Links ausgetauscht hast kann es sein das der Fehler für das Image auch weg ist, sollte der dann immer noch da sein melde dich bitte nochmal.

Schönen Gruß
Pascal

Racoon

Registriert: 17.11.2015
Beiträge: 148

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 09.05.2019 um 19:00:27   
Hallo,

Verlinkungen (href) auf unsichere Seiten sind nicht von Relevanz für die SSL-Verschlüsselung, da keine unsicheren sources geladen werden, sondern nur verwiesen wird.

Das Problem liegt, meiner Meinung nach, bei Afterbuy bzw. dem alten Shop-Template, da ASP.net-session-cookies von einer unsicheren Domain, nämlich www.afterbuy-shop.de, abgelegt werden. Anbei zwei Screenshots aus den Dev-Tools im Vergleich electromyne.de und demoshop.afterbuy.de. Belehrt mich bitte eines besseren, wenn dies nicht die Ursache sein sollte, aber für mich sieht das ganz klar danach aus.

falsch:
https://bilder.psywork.com/upload/electro_cookies.jpg

korrekt:
https://bilder.psywork.com/upload/demoshop_cookies.jpg

Viele Grüße,
René




geändert am 09.05.2019 19:02:29 von Racoon

electrom

Registriert: 11.08.2011
Beiträge: 296
Land: Deutschland

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 10.05.2019 um 08:31:39   
Hallo,

Ich habe schon zweimal die Fehlermeldung geschickt in der eindeutig auf ein image = Bild und kein Link verwiesen wird. Das Problem liegt, wie Racoon schon festgestellt hat bei Afterbuy.

Gruß
Denny

Dennis P.

[Afterbuy Support]

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 10.05.2019 um 09:42:12   
Wir haben dies per Quelltextanzeige kontrolliert und es wird darin kein Bild angezeigt, welches noch ein
HTTP Verweis haben könnte, daher ist die Meldung eher irritierend.

Könntest Du es bitte einmal mit einem neu erstellten Standard Design ausprobieren? Möglicherweise ist
dies dem alten Design geschuldet, welche nicht mehr unterstützt werden.

Gruß Dennis

geändert am 10.05.2019 09:48:53 von Dennis P.

Racoon

Registriert: 17.11.2015
Beiträge: 148

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 10.05.2019 um 09:55:08   
@Dennis

Die cookies von www.afterbuy-shop.de sind deiner Meinung nach nicht die Ursache?

electrom

Registriert: 11.08.2011
Beiträge: 296
Land: Deutschland

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 10.05.2019 um 10:03:26   
Hallo Dennis,

ich habe gerade ein neues Design erstellt und aktiviert. Die Seite wird als "sicher" angezeigt, also liegt es an einem Eintrag im Quellcode des alten Designs. Da ich darauf keinen Zugriff habe, muss der Fehler von euch behoben werden.

Gruß
Denny

Dennis P.

[Afterbuy Support]

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 10.05.2019 um 12:32:46   
Wie ich bereits mitteilte, werden die alten Designs leider nicht mehr unterstützt

Hier muß man in dem Fall entweder das eigenes Design, welches hier verwendet wird,
abändern (von jemanden der sich mit CSS/HTML/XSL auskennt, da wir keine Anpassungen bei eigenen
Designs vornehmen) oder man nutzt eines der neuen Designs, wo es die Problematiken nicht mehr gibt.

Gruß Dennis

geändert am 10.05.2019 12:33:12 von Dennis P.

electrom

Registriert: 11.08.2011
Beiträge: 296
Land: Deutschland

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 10.05.2019 um 12:45:56   
Hallo Dennis,

da die Session Cookies von einer unverschlüsselten Domain geladen werden und dadurch die Fehlermeldung erscheint, ist nun die Frage, wie lautet der korrekte Pfad der Ressource und an welcher Stelle bzw, in welchem Template kann ich dies abändern?

Gruß
Denny

Racoon

Registriert: 17.11.2015
Beiträge: 148

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 10.05.2019 um 13:20:28   
@Denny

Ich will mich nicht darauf festlegen, dass es wirklich daran liegt, aber ich vermute es stark. Deshalb ja auch die Frage an Dennis ob das die Ursache sein könnte. Wenn dem so ist, kannst du leider überhaupt nix machen um den Fehler selbst zu beseitigen. Wäre ja schon schön wenn in der Entwicklung mal nachgefragt wird und dann evtl. der Hinweis kommt, dass die alten Templates quasi nicht SSL-ready sind.

electrom

Registriert: 11.08.2011
Beiträge: 296
Land: Deutschland

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 10.05.2019 um 14:21:16   
@Dennis

Das alte benutzterdefinierte Design soll auf jedenfall beibehalten werden, da wir viel Arbeit und Zeit zur Anpassung investiert haben. Sollte SSL nur auf neuen Designs funktionieren, würden wir die Buchung wieder rückgängig machen. Vielleicht mal in der Entwicklung nachfragen wie es sich mit alten Templates und SSL verhält?

Gruß
Denny

electrom

Registriert: 11.08.2011
Beiträge: 296
Land: Deutschland

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 21.05.2019 um 11:47:10   
Hallo,

ich wollte nochmal nachfragen ob es denn eine Möglichkeit gibt, die alten Templates mit SSL zu nutzen?

Gruß
Denny

Dennis P.

[Afterbuy Support]

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 21.05.2019 um 12:00:17   
Ich klär das erst einmal ab, aber in der Regel wird von den alten Designs nichts mehr angepaßt
(auch neue alte Designs anlegen ist ja nicht mehr möglich), weshalb ein Wechsel zu einem neuen
Design normalerweise unumgänglich ist.

Gruß Dennis

Dennis P.

[Afterbuy Support]

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 23.05.2019 um 14:56:02   
So.... also das Design ist hier nicht mal direkt schuld, wie ich jetzt erfahren habe.

Was

"Mixed Content: The page at 'https://www.electromyne.de/' was loaded over HTTPS, but requested an insecure image 'http://www.afterbuy-shop.de/'. This content should also be served over HTTPS."

angeht, wird das von den Kollegen noch geprüft, aber was bei Dir generell ein Problem ist, mit SSL, liegt
mitunter auch an z.B. Deinen Kategorien. Du hast dort nämlich mitunter noch Kategoriebilder hinterlegt,
welche keinen Verweis auf HTTPS haben, und somit noch mit HTTP bestückt sind. Dies solltest Du auf
jeden Fall abändern, damit das dann auch danach korrekt funktionieren kann.

Gruß Dennis

Dennis P.

[Afterbuy Support]

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 23.05.2019 um 15:12:36   
Der Fehler mit " 'http://www.afterbuy-shop.de/'. scheint auf etwas zu beruhen, was bei Dir
integriert ist.

Es geht in Deinem Design um etwas, wie
"https://www.provenexpert.com/img/1_widget_02f52cb1e5ec24a9bd777aa1c02419.png1606"

Dieses löst diesen Fehler aus, was bedeutet, Du mußt hier einmal schauen, wo Du dies zu stehen haben
könntest, denn benennen könnte ich das jetzt nicht.

Gruß Dennis

electrom

Registriert: 11.08.2011
Beiträge: 296
Land: Deutschland

AW: Nach Umstellung auf SSL, Warnung Mixed Content      Antwort vom 24.05.2019 um 10:10:24   
Hallo Dennis,

danke für die Antwort, ich schau mir das gleich an. Und noch was, wenn ich auf das Startseitenlogo klicke, werde ich zur Afterbuy Startseite weitergeleitet obwohl der Link auf unsere Startseite zeigt. Dieser Fehler ist auch erst nach der Umstellung auf SSL.

Edit:
Das mit der Startseite funktioniert wieder, lag am Browser Cache.

Die Box mit dem besagten Link "https://www.provenexpert.com/img/1_widget_02f52cb1e5ec24a9bd777aa1c02419.png1606" habe ich entfernt, hat aber leider nix gebracht. Es erscheint immer noch folgende Fehlermeldung:

"Loading mixed (insecure) display content “http://www.afterbuy-shop.de/” on a secure page"

Gruß
Denny

geändert am 24.05.2019 10:32:20 von electrom

geändert am 24.05.2019 11:59:47 von electrom